
 Trodes   

Getting Started

1. Installation 

1) Install the FTDI D2XX driver for the USB driver.
2) Copy the downloaded Trodes directory to a desired location.
3) Double click on “Trodes” to start.

2. Controls overview 

We will start the tutorial by using the playback function to give a quick overview of 
Trodes with real data recorded from a mouse. Download the example recording 
and extract the folder.  The folder has two files in it:  a .rec file and a .trodesConf 
file with the same name. In Trodes, go to Connection->Source->File and select 
‘16ChannelRec.rec’.  This file has 16 channels, where the nTrodes are single-
channel bundles. Press the play button to start playback.

Now you should see data streaming across the screen, and if your computer has 
audio set up, you should hear audio for the currently highlighted channel. You 
can change the length of time displayed in the data streams by selecting a time 
option under View->Streaming->Trace length. You can toggle the coupling 
between the displayed streams from the spike filters under View->Streaming-
>Filters.

http://www.ftdichip.com/Drivers/D2XX.htm
http://www.spikegadgets.com/downloads/16ChannelRec.zip


 Along the top of the window, there are control buttons.  Here are their functions:

1) Link nTrodes — you can either enable or disable nTrode linking with this 
button.  When they are linked, any change in settings to one nTrode (such as 
reference or filter settings) are applied to all nTrodes.

2) Annotate — this button opens a dialog that is activated only when a recording 
file is open.  You can type any text into this dialog, the the strings will be 
timestamped and saved.  This allows you to take notes during the recording.

3) Video — this button starts the camera module

4) nTrode — this button opens a dialog with settings for the currently selected 
nTrode. To select a different nTrode, simply click on a channel in the 
streaming window to highlight it. 

5) Spikes — this button open a window displaying spike trigger events for the 
currently selected nTrode.

6) Audio — Opens a dialog to modify audio settings.

Notice that channel 1 is highlighted.  This indicates that channel 1 is the currently 
selected channel.  Audio is streamed for this channel, and the settings for the 
channel can be modified by pressing the ‘nTrode’ button.

With channel 1 selected, click on the ‘Spikes’ button.  A window will appear 
showing trigger events for channel 1.  You can change the voltage threshold  
used to define a trigger, and you can sort spikes in the scatter plot. If you click on 
a different channel in the main window, the open Spikes window will update to 
the selected channel.



Select the ‘Link nTrodes’ button to link changes across nTrodes. Then, press the 
‘nTrode’ button.  You’ll notice that bandpass filters are currently being applied to 
all channels (signified with the check mark in the spike filter section).  Uncheck 
this, and the filters will be deactivated and you will see lower frequency 
signatures in the traces.

�

Now, turn the filters back on.  You can also select a digital reference with this 
menu.  If one or more of your channels are designated as references, you can 
subtract its data from any other channel.

To change the display range on any strode, simple scroll the move wheel up and 
down when the mouse is over the channel(s) associated with the target nTrode. 
You can also change the display range in the Spikes window.  If you have ‘Link 
nTrodes’ selected, all display ranges will be modified together.

You can change the display color of any nTrode by right-clicking on it and 
selecting Change nTrode color.  You can also change the background color.

When data are processed offline, the functions use whichever settings are saved 
in the .trodesconf file to extract the data.  So, for example, if you want to modify 
the filters settings, spike threshold settings, or filter settings from the ones used 
during the recording, you can use the file playback mode to do this.  After you 
have modified the settings, go to File->Workspace->Save settings as… and 
make sure the name is the same as the recording file (but with the .trodesconf 
extension) and located in the same folder. Now, the next time you open the file 
for playback, the new settings will be used.



To disconnect from a source, select Connection->Disconnect.  This will stop 
streaming when you are connected to hardware.  During file playback, it stops 
playback and resets to file to the beginning. Now, select Connection->Source-
>None to close the playback file.

3. Acquiring data 

Before data can be acquired, a workspace needs to opened that tells Trodes how 
many channels to expect from the hardware and how to organize them (single 
channels, tetrodes, octrodes…). Download the workspace examples and extract 
the folder. For this tutorial, we will work with ‘128_Tetrodes_ECU.trodesconf’.  
This workspace sets up 128 channels for acquisition, all organized into 4-channel 
‘tetrodes’. It also expects data from the ECU, which streams auxiliary digital and 
analog data.

To open the workspace in Trodes, go to File->Workspace->Load, and select 
‘128_Tetrodes_ECU.trodesconf’. You’ll notice that there are multiple tabs to 
display all of the channels, plus an ‘Aux’ tab displaying the extra digital and 
analog lines from the ECU.  Not all ECU channels are displayed— this can be 
changed by editing the workspace file. Also, the Spikes window now shows 4 
trigger windows from every nTrode.

�

http://www.spikegadgets.com/downloads/Workspaces.zip


�

To connect to a data source, select a source from Connection->Source. In this 
example, we will use the Signal Generator, which produces a sine wave on all 
channels and does not require any hardware (to modify the generated sine wave, 
open up Connection->Generator controls). If you already have hardware 
available, you can select that (example: Source->SpikeGadgets->USB). 
Otherwise, select Connection->Source->Signal Generator. Then, to start 
streaming data, select Connection->Stream from source.

�

4. Recording to disk 

To start recording, you must first create an output file. Select File->Create file for 



recording to open a save dialog. You’ll notice that a default name is entered into 
the save dialog, such as ‘myAnimal03-15-2016(12_12_30).rec’.  The ‘myAnimal’ 
part of the name is there because the workspace has a declared default prefix for 
the name.  This is described in further detail in the workspace section below. The 
rest of the file indicates the date and time of the recording.  You can use a 
different name, as long as you follow the following convention to make other 
modules and the offline file processing code behave normally:

1) Do not use the underscore character (‘_’ ).
2) Do not use spaces.

Also, each recording session should be placed in a dedicated folder. A recording 
session can have multiple files, in which case it is best to keep acquisition 
running in between file closure/creation to keep the temporal relationship of the 
recordings intact.

Once you have entered the desired file path and name, click ‘Save’. Now, at the 
top of the window you will see the .rec file name, plus indicators for the current 
file size and amount of storage available.

�

Start streaming data (see above), and then select File->Record to start saving 
data. Alternatively, you can press the record button at the top of the window. You 
can pause recording at any time— this does not close the file but simply stops 
logging. When the record button is pressed, logging continues (with a gap of data 
in between).  

You are not allowed to stop/start acquisition once logging has begun. You must 
close the file first. This is to ensure that no time resets occur within a single log 
file.



Once the file is open, you can annotate events during the recording using the 
‘Annotate’ button.  Write a line into the dialog and press ‘Enter’.  The line will be 
tagged with the current timestamp and seven to a text file. Upon the first 
annotation, a new file will be created in the same directory as the .rec file, but 
with the .trodesComments extension.

To close the file after the recording is complete, select File->Close file.

5. The workspace 

Workspace files are written in xml format, so you can use an editor to open it and 
edit the contents. Here are the sections of the workspace file.

1) GlobalConfiguration section. This section contains general settings:

<GlobalConfiguration filePrefix = "myAnimal" 
saveDisplayedChanOnly="1" filePath="" realtimeMode=“0"/>

Here are the definitions for the fields:

filePrefix — text appended to the default names of created log files.  Usually 
the animals ID

filePath — the default location where log files are stored. This should be 
changed to an existing directory on your machine.

saveDisplayedChanOnly — can be 1 or 0.  If set to 1, then Trodes will only 
save the channels that are displayed.  Otherwise, all hardware channels are 
saved regardless of whether they are displayed or not.

realtimeMode — can be 1 or 0.  If set to 1, the CPU works much harder to try 
to retain low processing latencies for closed-loop experiments.  

2) HardwareConfiguration section. 

<HardwareConfiguration numChannels="128" 
samplingRate="30000">

This section contains two fields about the data, plus child nodes describing 
additional hardware devices that are enabled to stream data alongside the 
neural data.

numChannels — a number in multiples of 32 defining how many channels 
are coming from the hardware.



samplingRate — the sampling frequency of the hardware.  The default is 
30000. 

This child nodes in this section contain low-level information about what 
hardware is connected to the system. This information is not intended to be 
changed, except for one field— the “available” field. If set to 1, then Trodes 
will expect data from this device in the incoming data stream. 

3) ModuleConfiguration section.  

This section tells Trodes which modules to open along with the workspace.  In 
this workspace, the camera and StateScript modules are defined.

4) StreamDisplay section. 

This section controls details about the display of streaming data. It contains 
two fields:

<StreamDisplay columns="4" backgroundColor="#030303"/>

columns — the number of display windows to divide the channel streams 
into
backgroundColor — the background.  This can be change within Trodes by 
right-clicking inside any of the stream window columns.

5) AuxDisplayConfiguration section. 

This section defines which digital I/O and auxiliary analog channel to display.  
Channels are selected from the available menu defined in the 
HarwareConfiguration section. Each DispChannel section defined one 
channel:

<DispChannel id="Din1" maxDisp="2" color="#aaaaaa" 
device="ECU"/>

Here are the field definitions for a DispChannel:

id — The displayed name of the channel. This should match the id defined in 
the HarwareConfiguration section.
maxDisp — the maximum display range of the trace.
color — the displayed trace color
device — The name of the hardware device. This should match the device 
name in the HarwareConfiguration section.

6) SpikeConfiguration section. 



This section defines how channels are bundled and processed for spike 
detection. Each child node is a SpikeNTrode, which has the following fields:

<SpikeNTrode highFilter="6000" color="#ffffff" 
lowFilter="600" LFPHighFilter="200" refChan="1" refOn="0" 
id="1" LFPChan="1" moduleDataOn="1" filterOn="1" 
refNTrode=“1">

id — defines the name of the nTrode.  This should be a 1-based number

refOn — 1 or 0.  If 1, then the defined reference channel is subtracted from 
all channel in the nTrode.

refNTrode — the nTrode number of the reference

refChan — the channel in the reference nTrode to use for the reference

filterOn — 1 or 0. If 1, the spike filter is turned on.

lowFilter — this is the lower range of the bandpass spike filter (200, 300, 400 
500, 600 allowed)

highFilter — this is the upper range of the bandpass spike filter (5000 or 
6000 allowed)

moduleDataOn — 1 or 0.  Defines if LFP data from moduleDataChan should 
be sent to other modules

LFPChan — Defines the LFP channel to process offline, and which channel 
to send to other modules for online LFP  pattern detection.

LFPHighFilter — define the low-pass filter for the LFP channel (100, 200, 
300, 400, and 500 allowed)

color — the display color of the channel

Each SpikeNTrode section has at least one SpikeChannel child node.  If 
there are n SpikeChannel children, then all n channels are bundled together, 
where if any one channel goes above threshold, then a spike is triggered on 
all channels of the nTrode. Here is one SpikeChannel:

<SpikeChannel thresh="30" maxDisp="200" hwChan="63" 
triggerOn=“1”/>

Each SpikeChannel has the following fields:



thresh — the trigger threshold for this channel.  All channel of an nTrode 
should have the same threshold.

maxDisp — the maximum display range of the channel

hwChan — the 0-based hardware channel that this channel maps to.

triggerOn — 1 or 0.  Defines whether or not this channel can cause a trigger 
event for the nTrode. This option is available if the channel is too noisy to be a 
reliable trigger channel.

Here is the entire first SpikeNTrode node (with four SpikeChannel child nodes 
to define a tetrode):

<SpikeNTrode highFilter="6000" color="#ffffff" 
lowFilter="600" LFPHighFilter="200" refChan="1" refOn="0" 
id="1" LFPChan="1" moduleDataOn="1" filterOn="1" 
refNTrode="1">
   

<SpikeChannel maxDisp="200" hwChan="63" triggerOn="1" 
thresh="30"/>

   
<SpikeChannel maxDisp="200" hwChan="61" triggerOn="1" 
thresh="30"/>

   
<SpikeChannel maxDisp="200" hwChan="57" triggerOn="1" 
thresh="30"/>

  
 <SpikeChannel maxDisp="200" hwChan="59" triggerOn="1" 
thresh="30"/>

</SpikeNTrode>

6. Using modules 

If one or more modules are defined in your workspace, they will open 
automatically when the workspace is created.  Some modules can be launched 
without being configured in workspace by using the menu bar.  

All modules receive receive notifications when sources are selected, acquisition 
is started/stopped, files are created/closed, and when logging is started/paused. 
Custom-written modules should be written to respond appropriately to these 
notifications.



1) Camera Module

The camera module allows users to collect video from web cams or GIGE 
cameras and timestamp the frames. It also will perform rodent position tracking in 
multiple modes (black on white background, single LED, and dual red-green 
LED’s for head direction). The module can also be opened on its own for offline 
position tracking.

When a file is created in Trodes, the camera module will create a video file 
(.h264 extension) and a frame timestamp file (.videoTimeStamps extension) with 
the same name as the .rec file. If acquisition is paused in Trodes, it is also 
paused in the camera module. 

Along the top of the window, there are control buttons similar to the layout in the 
Trodes main program. These buttons are slightly different during ‘slave mode’ 
and ‘standalone mode’.  During ‘slave mode’, the camera module acts as a slave 
to Trodes, and the buttons have the following functions:

Track — used to toggle position tracking (logged to disk if saving is underway)

Tools — opens the tool selector window.  Available tools include a manual 
position input tool, an include region tool, and an exclude region tool.

Source — used to select which available camera to use.  USB webcams and 
Allied Vision GIGE cameras are automatically detected.

Settings — opens a dialog to adjust position tracking settings

 
In ‘Standalone mode’ the program is opened directly (not through Trodes). The 
control buttons are different in this case:

Log — initiates and ends offline position tracking and logging to file

Tools — save as above

File — used to open a video file

Settings — same as above



2) StateScript Module

The StateScript Module is used to send scripts and commands to the ECU, 
which is running StateScript control firmware. Like the camera module, it can be 
opened in two modes: slave mode (through Trodes) or standalone mode (opened 
directly). Standalone mode is useful for controlling the experimental  environment 
when no electrophysiology is being performed.  

�

When the module is opened, it displays three sub panels.  The top two windows 
are file selection windows.  They should display your directories with StateScript 
scripts (left window) and your observer scripts (right window).  To change the 
default folders shown, select File->Script folders->Scripts (for StateScripts) 
and File->Script folders->Observer scripts (for observer scripts based in 
matlab or python). If you double-click on a file in the left (StateScript) window, the 
StateScript editor will open the script for editing, as shown in the screenshot 
above. The bottom window is the console window, which is inactive until the 
module is connected to hardware running StateScript.

To connect to the hardware, press the Source button and choose your hardware 
from the drop down list (if using the ECU, select ‘ECU’) and press Connect. The 
window on the bottom will turn white and an vitiation sequence will appear.  If 
connection goes smoothly, you should be able to type ‘;’ followed by RETURN in 
the console window and a ‘~~~’ will be returned indicating that your command 
was compiled successfully.

In slave mode, there are four control buttons at the top of the window:



Send script — when pressed, the selected StateScript is sent to hardware for 
compilation. 

Clear/Stop — stop execution of the script and clears variables.

Local — starts the observer scripting environment (Matlab or Python).  Click on 
the ‘Observer’ tab to see the console for the observer environment. To set up the 
observer environment select Edit->Observer language…

Controller — used to select and connect to hardware.

In slave mode, logging to file is controlled from Trodes, where file creation, 
logging start/stop, and file closing occur alongside the same actions for the 
recording files. 

In standalone mode, the buttons at the top of the window are different:

Start — sends the selected StateScript to hardware and automatically sets up a 
log file for recording events.

Clear/stop — same as above

Local — same as above

Camera — open the camera module to record video of the experiment

Controller — same as above


